Issue with relayed connections in the EU region

Incident Report for Epic Games Public

Monitoring

A fix has been deployed. We are monitoring the health of our relay servers to ensure the issue is resolved.
Posted Dec 03, 2025 - 20:40 UTC

Investigating

We are currently investigating an issue with P2P relayed connections in the EU region.
Posted Dec 03, 2025 - 16:30 UTC
This incident affects: Epic Online Services (Peer-to-Peer (P2P)).