Rocket League Matchmaking and Connection Issues

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 02:37 UTC

Update

We are continuing to investigate this issue.
Posted Mar 26, 2025 - 00:52 UTC

Investigating

We are aware players are experiencing matchmaking and connection issues in Rocket League after our v2.50 update.
We're investigating and will provide an update once this is resolved.
Posted Mar 25, 2025 - 23:19 UTC
This incident affected: Rocket League (Login, Game Services, Matchmaking, Stats and Leaderboards, Item Shop, Parties, Friends, and Messaging, Voice Chat).