Epic Games Store: Purchases Not Completing in Launcher
Incident Report for Epic Games Public
Resolved
We've released the fix for this issue. If you find that your purchases in the launcher still aren't completing, please try closing and re-opening the launcher.
Posted Apr 05, 2021 - 21:45 UTC
Identified
We're aware of an issue currently blocking players from completing purchases in the Epic Games launcher. (Please note that purchases in the web store are still working properly.)
Posted Apr 05, 2021 - 21:37 UTC
This incident affected: Epic Games Store (Login).