Emergency EOS Maintenance

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted 11 days ago. Mar 24, 2025 - 14:59 UTC

Monitoring

EOS Maintenance has concluded and we’re continuing to monitor stability for Session and Lobby services.

Thank you for your patience.
Posted 14 days ago. Mar 22, 2025 - 01:19 UTC

Update

Unfortunately, we've had to enter maintenance sooner (March 21 - 8:15 pm EST).

During the maintenance window, there will be degraded availability for the following services:

- Sessions
- Lobbies

We will provide an update once maintenance has concluded.
Posted 14 days ago. Mar 22, 2025 - 00:12 UTC

Investigating

Epic Online Services is scheduled for maintenance on 22 March, 1 am EST. During the maintenance window, there will be 4 hours of degraded availability for the following services:

- Sessions
- Lobbies

Thank you for your patience.
Posted 14 days ago. Mar 21, 2025 - 19:08 UTC
This incident affected: Epic Online Services (Lobbies, Sessions).