EU + MENA Regions: Returned to Lobby
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted 5 months ago. May 16, 2019 - 21:48 UTC
Investigating
We're aware some players in EU and MENA regions are being sent back to the lobby when in a game or searching for a match.

We are working to fix this issue and will provide a status update once it's resolved.
Posted 5 months ago. May 16, 2019 - 15:24 UTC