Store Purchase Loading Errors
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 06, 2019 - 21:09 UTC
Update
We are continuing to work on a fix for this issue.
Posted 3 months ago. Jun 06, 2019 - 21:04 UTC
Identified
We're aware of an issue causing the purchase flow to fail to load in the store

We've identified the issue and will provide an update when it is fixed.
Posted 3 months ago. Jun 06, 2019 - 17:16 UTC
This incident affected: Epic Games store.