EOS Matchmaking Issues

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Dec 24, 2025 - 01:23 UTC

Investigating

We are investigating matchmaking issues affecting Epic Online Services and are working on a solution.
We'll provide an update once the issues have been resolved.
Posted Dec 24, 2025 - 00:56 UTC