Delayed Email Delivery

Incident Report for Epic Games Public

Resolved

This issue has been resolved! Emails should now be arriving on time.

Thank you for your patience.
Posted Sep 18, 2020 - 22:17 UTC

Investigating

We're investigating reports of delayed email deliveries and are working to fix this issue.

We'll provide an update once the problem has been resolved.
Posted Sep 18, 2020 - 18:43 UTC