Epic Games Launcher: Reduced Download Speeds in Certain Regions
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Sep 03, 2020 - 12:58 UTC
Investigating
We're seeing reduced download speeds on the Epic Games Launcher in certain regions. This may result in the "Please wait..." message being shown for an extended time.
Posted Aug 27, 2020 - 14:19 UTC
This incident affected: Epic Games Store (Login).