PS4 Redeeming Purchases Issue
Incident Report for Epic Games Public
Resolved
We've resolved the issue preventing PS4 players from redeeming purchases. If you made a purchase please restart your client and your items will be available.
Posted Dec 03, 2019 - 01:30 UTC
Investigating
We're investigating an issue that is preventing PS4 players form redeeming purchases.
Posted Dec 02, 2019 - 23:23 UTC