Sideswipe Matchmaking Issues

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted May 06, 2025 - 19:08 UTC

Investigating

We are aware of matchmaking issues in Rocket League Sideswipe and are actively investigating.
Posted May 06, 2025 - 18:50 UTC
This incident affected: Rocket League Sideswipe (Login, Game Services, Matchmaking, Stats & Leaderboards, Item Shop, Parties, Friends, and Messaging).