Fortnite Matchmaking Issues

Incident Report for Epic Games Public

Resolved

✅ Matchmaking services for Fortnite Battle Royale are now fully restored.
Posted Nov 21, 2025 - 17:31 UTC

Identified

⚠️ We're actively working on resolving an issue causing some players to experience matchmaking difficulties in Fortnite Battle Royale.

We'll provide an update once matchmaking has returned to normal.
Posted Nov 21, 2025 - 16:12 UTC
This incident affected: Fortnite (Matchmaking).